HTTP Plug-in not working with Websphere virtual host - Websphere

This is a discussion on HTTP Plug-in not working with Websphere virtual host - Websphere ; Hi Greetings, I am having an issue with IBM HTTP plug-in for version 6.1, both WAS and HTTP are on the same machine. I am using version 6.1 of WAS and HTTP servers. I have configured the http server to ...

+ Reply
Results 1 to 7 of 7

Thread: HTTP Plug-in not working with Websphere virtual host

  1. #1
    Senior Member
    Join Date
    Jan 2010
    Posts
    3,680

    Default HTTP Plug-in not working with Websphere virtual host

    Hi Greetings,

    I am having an issue with IBM HTTP plug-in for version 6.1, both WAS and HTTP are on the same machine.

    I am using version 6.1 of WAS and HTTP servers. I have configured the http server to listen on default port 80 and the WAS is listening on default port 9080 also for WAS I have configured a virtual host which listens on port 82 and it works fine as I can access http://localhost:82/snoop.

    I have also installed plug-in for HTTP server and it works fine with default setting. However when I point the default application (snoop) to virtualhost which is on port 82 I can not access it from http server and I get the following trace messages in plain trace file.

    Please recommend.

    Thanks,
    Ravi

    DEBUG: lib_util: parseHostHeader: Defaulting port for scheme 'http'
    DEBUG: lib_util: parseHostHeader: Host: 'ceginfv-msw-07', port 80
    DEBUG: ws_common: websphereCheckConfig: Current time is 1172003153, next stat time is 1172003091
    DEBUG: ws_common: websphereCheckConfig: Latest config time is 1172000434, lastModTime is 1172000434
    DETAIL: ws_common: websphereShouldHandleRequest: trying to match a route for: vhost='ceginfv-msw-07'; uri='/snoop'
    DEBUG: ws_common: webspherePortNumberForMatching: Using logical.
    TRACE: ws_common: websphereVhostMatch: Comparing '*:443' to 'ceginfv-msw-07:80' in VhostGroup: default_host
    TRACE: ws_common: websphereVhostMatch: Comparing '*:5061' to 'ceginfv-msw-07:80' in VhostGroup: default_host
    TRACE: ws_common: websphereVhostMatch: Comparing '*:5060' to 'ceginfv-msw-07:80' in VhostGroup: default_host
    TRACE: ws_common: websphereVhostMatch: Comparing '*:9443' to 'ceginfv-msw-07:80' in VhostGroup: default_host
    TRACE: ws_common: websphereVhostMatch: Comparing '*:80' to 'ceginfv-msw-07:80' in VhostGroup: default_host
    DEBUG: ws_common: websphereVhostMatch: Found a match '*:80' to 'ceginfv-msw-07:80' in VhostGroup: default_host with score 1, exact match 0
    TRACE: ws_common: websphereVhostMatch: Comparing '*:9080' to 'ceginfv-msw-07:80' in VhostGroup: default_host
    TRACE: ws_common: websphereUriMatch: uri length smaller than uri defs so skipping the rest
    TRACE: ws_common: websphereUriMatch: Failed to match: /snoop
    DEBUG: ws_common: webspherePortNumberForMatching: Using logical.
    TRACE: ws_common: websphereVhostMatch: Comparing '*:82' to 'ceginfv-msw-07:80' in VhostGroup: bo_host
    TRACE: ws_common: websphereVhostMatch: Failed to match: ceginfv-msw-07:80
    DETAIL: ws_common: websphereShouldHandleRequest: No route found
    TRACE: mod_was_ap20_http: as_handler: In the app server handler
    TRACE: mod_was_ap20_http: in as_logger

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Posts
    3,680

    Default Re: HTTP Plug-in not working with Websphere virtual host

    Sorry forgot to put my plugin-cfg.xml file

    <?xml version="1.0" encoding="ISO-8859-1"?>
    <!--HTTP server plugin config file for the webserver CEGINFV-MSW-07Node01Cell.CEGINFV-MSW-07Node01.webserver1 generated on 2007.02.20 at 02:40:31 PM EST-->
    <Config ASDisableNagle="false" AcceptAllContent="false" AppServerPortPreference="WebserverPort" ChunkedResponse="false" FIPSEnable="false" IISDisableNagle="false" IISPluginPriority="High" IgnoreDNSFailures="false" RefreshInterval="60" ResponseChunkSize="64" VHostMatchingCompat="false">
    <Log LogLevel="Trace" Name="C:\Program Files\IBM\HTTPServer\Plugins/logs/webserver1/http_plugin.log"/>
    <Property Name="ESIEnable" Value="true"/>
    <Property Name="ESIMaxCacheSize" Value="1024"/>
    <Property Name="ESIInvalidationMonitor" Value="false"/>
    <VirtualHostGroup Name="bo_host">
    <VirtualHost Name="*:82"/>
    </VirtualHostGroup>
    <VirtualHostGroup Name="default_host">
    <VirtualHost Name="*:9080"/>
    <VirtualHost Name="*:80"/>
    <VirtualHost Name="*:9443"/>
    <VirtualHost Name="*:5060"/>
    <VirtualHost Name="*:5061"/>
    <VirtualHost Name="*:443"/>
    </VirtualHostGroup>
    <ServerCluster CloneSeparatorChange="false" IgnoreAffinityRequests="true" LoadBalance="Round Robin" Name="server1_CEGINFV-MSW-07Node01_Cluster" PostBufferSize="64" PostSizeLimit="-1" RemoveSpecialHeaders="true" RetryInterval="60">
    <Server ConnectTimeout="0" ExtendedHandshake="false" MaxConnections="-1" Name="CEGINFV-MSW-07Node01_server1" ServerIOTimeout="0" WaitForContinue="false">
    <Transport Hostname="CEGINFV-MSW-07.Ceg.Corp.Net" Port="9080" Protocol="http"/>
    <Transport Hostname="CEGINFV-MSW-07.Ceg.Corp.Net" Port="9443" Protocol="https">
    <Property Name="keyring" Value="C:\Program Files\IBM\HTTPServer\Plugins/config/webserver1/plugin-key.kdb"/>
    <Property Name="stashfile" Value="C:\Program Files\IBM\HTTPServer\Plugins/config/webserver1/plugin-key.sth"/>
    </Transport>
    <Transport Hostname="CEGINFV-MSW-07.Ceg.Corp.Net" Port="82" Protocol="http"/>
    </Server>
    </ServerCluster>
    <UriGroup Name="bo_host_server1_CEGINFV-MSW-07Node01_Cluster_URIs">
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/AnalysisHelp/*"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/snoop/*"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/hello"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/hitcount"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="*.jsp"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="*.jsv"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="*.jsw"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/j_security_check"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/ibm_security_logout"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/servlet/*"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/businessobjects/enterprise115/adhoc/*"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/businessobjects/enterprise115/adminlaunch/*"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/businessobjects/enterprise115/desktoplaunch/*"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/dswsbobje/*"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/jsfadmin/*"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/styles/*"/>
    </UriGroup>
    <Route ServerCluster="server1_CEGINFV-MSW-07Node01_Cluster" UriGroup="bo_host_server1_CEGINFV-MSW-07Node01_Cluster_URIs" VirtualHostGroup="bo_host"/>
    <UriGroup Name="default_host_server1_CEGINFV-MSW-07Node01_Cluster_URIs">
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/ivt/*"/>
    <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/businessobjects/*"/>
    </UriGroup>
    <Route ServerCluster="server1_CEGINFV-MSW-07Node01_Cluster" UriGroup="default_host_server1_CEGINFV-MSW-07Node01_Cluster_URIs" VirtualHostGroup="default_host"/>
    <RequestMetrics armEnabled="false" loggingEnabled="false" rmEnabled="false" traceLevel="HOPS">
    <filters enable="false" type="URI">
    <filterValues enable="false" value="/snoop"/>
    <filterValues enable="false" value="/hitcount"/>
    </filters>
    <filters enable="false" type="SOURCE_IP">
    <filterValues enable="false" value="255.255.255.255"/>
    <filterValues enable="false" value="254.254.254.254"/>
    </filters>
    <filters enable="false" type="JMS">
    <filterValues enable="false" value="destination=aaa"/>
    </filters>
    <filters enable="false" type="WEB_SERVICES">
    <filterValues enable="false" value="wsdlPort=aaap=bbb:nameSpace=ccc"/>
    </filters>
    </RequestMetrics>
    </Config>




  3. #3
    Senior Member
    Join Date
    Jan 2010
    Posts
    3,680

    Default Re: HTTP Plug-in not working with Websphere virtual host

    Ravi,
    Not clear to me which process you've got listening to port 82, the
    application server or http server? They can't both be.
    Ken

    post_box8atyahoodotco.in wrote:
    > Hi Greetings,
    >
    > I am having an issue with IBM HTTP plug-in for version 6.1, both WAS and HTTP are on the same machine.
    >
    > I am using version 6.1 of WAS and HTTP servers. I have configured the http server to listen on default port 80 and the WAS is listening on default port 9080 also for WAS I have configured a virtual host which listens on port 82 and it works fine as I can access http://localhost:82/snoop.
    >
    > I have also installed plug-in for HTTP server and it works fine with default setting. However when I point the default application (snoop) to virtualhost which is on port 82 I can not access it from http server and I get the following trace messages in plain trace file.
    >
    > Please recommend.
    >
    > Thanks,
    > Ravi
    >
    > DEBUG: lib_util: parseHostHeader: Defaulting port for scheme 'http'
    > DEBUG: lib_util: parseHostHeader: Host: 'ceginfv-msw-07', port 80
    > DEBUG: ws_common: websphereCheckConfig: Current time is 1172003153, next stat time is 1172003091
    > DEBUG: ws_common: websphereCheckConfig: Latest config time is 1172000434, lastModTime is 1172000434
    > DETAIL: ws_common: websphereShouldHandleRequest: trying to match a route for: vhost='ceginfv-msw-07'; uri='/snoop'
    > DEBUG: ws_common: webspherePortNumberForMatching: Using logical.
    > TRACE: ws_common: websphereVhostMatch: Comparing '*:443' to 'ceginfv-msw-07:80' in VhostGroup: default_host
    > TRACE: ws_common: websphereVhostMatch: Comparing '*:5061' to 'ceginfv-msw-07:80' in VhostGroup: default_host
    > TRACE: ws_common: websphereVhostMatch: Comparing '*:5060' to 'ceginfv-msw-07:80' in VhostGroup: default_host
    > TRACE: ws_common: websphereVhostMatch: Comparing '*:9443' to 'ceginfv-msw-07:80' in VhostGroup: default_host
    > TRACE: ws_common: websphereVhostMatch: Comparing '*:80' to 'ceginfv-msw-07:80' in VhostGroup: default_host
    > DEBUG: ws_common: websphereVhostMatch: Found a match '*:80' to 'ceginfv-msw-07:80' in VhostGroup: default_host with score 1, exact match 0
    > TRACE: ws_common: websphereVhostMatch: Comparing '*:9080' to 'ceginfv-msw-07:80' in VhostGroup: default_host
    > TRACE: ws_common: websphereUriMatch: uri length smaller than uri defs so skipping the rest
    > TRACE: ws_common: websphereUriMatch: Failed to match: /snoop
    > DEBUG: ws_common: webspherePortNumberForMatching: Using logical.
    > TRACE: ws_common: websphereVhostMatch: Comparing '*:82' to 'ceginfv-msw-07:80' in VhostGroup: bo_host
    > TRACE: ws_common: websphereVhostMatch: Failed to match: ceginfv-msw-07:80
    > DETAIL: ws_common: websphereShouldHandleRequest: No route found
    > TRACE: mod_was_ap20_http: as_handler: In the app server handler
    > TRACE: mod_was_ap20_http: in as_logger


  4. #4
    Senior Member
    Join Date
    Jan 2010
    Posts
    3,680

    Default Re: HTTP Plug-in not working with Websphere virtual host

    Hi Ken,

    I have only one process listening on port 82 and that is a virtual host that I configured in WAS and then changed my default application (/snoop) to this virtual host.

    Regards,
    Ravi

  5. #5
    Senior Member
    Join Date
    Jan 2010
    Posts
    3,680

    Default Re: HTTP Plug-in not working with Websphere virtual host

    On Feb 21, 12:14 am, <post_b...atyahoodotco.in> wrote:
    > I have only one process listening on port 82 and that is a virtual host that I configured in WAS and then changed my default application (/snoop) to this virtual host.


    Your URI definition sais "/snoop/*" but you try to reach "/
    snoop" (without trailing /), so this doesn't match.

    Wkr,
    Sven Vermeulen


  6. #6
    Senior Member
    Join Date
    Jan 2010
    Posts
    3,680

    Default Re: HTTP Plug-in not working with Websphere virtual host

    post_box8atyahoodotco.in wrote:
    > Hi Ken,
    >
    > I have only one process listening on port 82 and that is a virtual host that I configured in WAS and then changed my default application (/snoop) to this virtual host.
    >
    > Regards,
    > Ravi


    So that virtual host is ignoring requests for port 80, so when you go
    through your HTTP server, no virtual host matches /snoop on port 80.

    Ken

  7. #7
    Senior Member
    Join Date
    Jan 2010
    Posts
    3,680

    Default Re: HTTP Plug-in not working with Websphere virtual host

    Ken Hygh a écrit :
    > post_box8atyahoodotco.in wrote:
    >> Hi Ken,
    >>
    >> I have only one process listening on port 82 and that is a virtual
    >> host that I configured in WAS and then changed my default application
    >> (/snoop) to this virtual host.
    >>
    >> Regards,
    >> Ravi

    >
    > So that virtual host is ignoring requests for port 80, so when you go
    > through your HTTP server, no virtual host matches /snoop on port 80.
    >
    > Ken

    Or may be you have to add the Transport HTTP port number 82 to the web
    container of your Application Server

+ Reply